Back to overview
Degraded

⚠️ UPI Payment Response Issue - Service Alert

Jan 13, 2026 at 05:42am UTC
Affected services
finkup.com

Resolved
Jan 26, 2026 at 05:47am UTC

The earlier issue affecting UPI payment responses has now been successfully resolved. All UPI transactions are processing normally, and payment status updates (success/failure) are reflecting correctly.

We appreciate your patience and apologize for the inconvenience caused.
If you continue to face any issues, please reach out to FinkUP support.
Support : 08062181646

Created
Jan 13, 2026 at 05:42am UTC

We are currently experiencing an intermittent UPI payment response problem affecting payment confirmations and status updates for some users. Our systems are actively investigating the cause of the issue to restore full functionality as soon as possible.

During this period, UPI transactions may show delayed or unclear responses (e.g., pending, timeout, or no immediate confirmation), although funds may have been debited or processed in the background. Delays in UPI payment status updates can occur due to high network traffic, connectivity errors, or upstream payment gateway delays.